PyroSim 的偏好设置可以通过前往文件(File)菜单并选择偏好设置…(Preferences…)来进行。所有偏好设置的更改将在当前 PyroSim 会话中生效,并在下次启动 PyroSim 时被记住。偏好设置分为几个类别,包括常规(General)、记录视图(Record View)、FDS、结果(Results)和渲染(Rendering)偏好设置。
常规偏好设置

FDS 文件格式
- 格式化 FDS 文件以便阅读(Format FDS file for easy reading):控制 PyroSim 生成的 FDS 输入文件中实数的格式。选中后,如果实数的绝对值大于等于 0.001 且小于 10000,则以十进制表示法写入;否则以科学计数法写入。
- 精度上限(Max precision):控制写入输入文件的有效数字位数。
文件与编辑
- 近期文件数量(Number of Recent Files):设置文件 > 近期 PyroSim 文件或文件 > 近期 FDS 文件菜单中将显示的文件数量上限。
- 撤销/重做历史(Undo/Redo History):设置撤销/重做功能记住的编辑上限数。
自动保存(Autosave)
指示 PyroSim 定期创建当前模型的备份。当 PyroSim 模型关闭时,此备份将被删除。如果 PyroSim 崩溃或计算机断电,此备份很有用。备份文件存储在与 PyroSim 文件相同的目录下。

如果您的工作文件(例如 testing.psm)损坏,可以找到以波浪号开头的文件,如 ~testing.psm。如果您遇到崩溃,此文件有时是优选恢复方案,因为它是崩溃前的工作内容。如果该文件无法打开或导致立即崩溃,还有一个备份文件可供选择。
默认设置启用此功能并每 10 分钟保存一次。在某些情况下,处理大型模型时,保存过程可能导致意外滞后,有些用户更倾向于禁用此功能并手动保存。
打开时创建备份(Create Backup on Open)
控制 PyroSim 是否在成功打开文件后创建 PyroSim 文件的备份副本。此备份在主 PyroSim 文件关闭后仍保留在磁盘上,因此可以在主文件损坏时使用。
如果您的工作文件或自动备份文件损坏,可以找到自动保存的备份文件,其扩展名包含波浪号,如 testing.~sm。建议重命名(或删除)当前工作文件,然后将备份文件的扩展名中的波浪号(.~sm)更改为 p 字符,得到 .psm。之后可以正常打开新的 .psm 文件。
注意:如果启用此选项,根据文件复制到备份的速度,PyroSim 文件的加载时间可能会稍长。
其他常规设置
- 记录预览(Record Preview):在 PyroSim 的许多对话框中添加预览窗格,显示将为 FDS 输入文件生成的文本。这对希望了解 PyroSim 选项如何对应 FDS 输入的用户很有帮助。
- 启动时显示启动画面(Show Splash Screen on Startup):控制启动 PyroSim 时是否显示启动画面。
- 崩溃时始终提示附加信息(Always Prompt for Additional Info on Crash):启用后,当应用程序发现崩溃时,PyroSim 将提示提供更多信息以帮助故障排查,并可向 Thunderhead 发送崩溃报告。
- 列表编辑器保存提示(List Editors Prompt to Save):禁用后,列表对话框(如 PyroSim 中的网格对话框)在切换到列表中其他项目时将跳过保存更改的提示。这些提示有助于防止意外更改,但有些用户可能觉得它们比较烦人。禁用此选项可使基于列表的属性对话框中的数据输入更有效。
- 键盘快捷键(Keyboard Shortcuts):启动用于将各种 PyroSim 编辑映射到用户自定义快捷键的对话框。
键盘快捷键配置

键盘快捷键对话框从 PyroSim 偏好设置面板启动。这些偏好设置将修饰键(ALT、CTRL、SHIFT 等)与普通按键组合绑定以激活 PyroSim 编辑。
该对话框分为六个部分:
- 文件(File):常见的文件菜单编辑。
- 编辑(Edit):常见的编辑菜单编辑。
- 视图(View):更新建模面板中相机位置的编辑,以及创建/修改视图(Views)的视点和截面框。
- 选择(Selection):对当前选择应用上下文菜单编辑。
- 上下文(Context):创建/修改标签和应用网格细化的编辑。
- 工具(Tool):通常用于绘制或手动操控模型,或切换视图工具。
要更改某个编辑的快捷键绑定,请点击”按键(Key Press)”列中的值,这将启动编辑器窗口(图4),提供四个选项:
- 等待输入(Awaiting Input):按下键盘按键以分配所需的快捷键绑定并将其映射到编辑。
- 取消(Cancel):退出编辑器窗口而不做任意更改。
- 重置(Reset):将该编辑恢复到默认的快捷键绑定。
- 清除(Clear):删除该编辑当前分配的快捷键绑定。

某些键盘快捷键可能被 Java UI 组件占用。如果某个快捷键未产生预期行为,可能是与预设的 Java 快捷键直接冲突。更好的做法是避免这些冲突(请参阅 Swing 默认快捷键绑定文档)。
记录视图偏好设置

这些偏好设置控制 FDS 输入文件在记录视图中的显示结果:
- 字体大小(Font Size):更改用于显示 FDS 输入文件的文本大小。
- 启用语法高亮(Enable Syntax Highlighting):控制 PyroSim 是否使用颜色来提高 FDS 输入文件的可读性。禁用此选项将使记录视图更新更快并消耗更少内存。
- 设置 HOLE 和 OBST 记录高亮限制(Set Limit for Highlighting HOLE and OBST records):设置 FDS 输入文件中要高亮的 HOLE 和 OBST 记录总数,以提高可读性。增大此值会减少性能并消耗更多内存,减小此值则提高性能并消耗更少内存。
FDS 偏好设置

可执行文件位置
允许您指定 PyroSim 使用的 FDS 和 Smokeview 可执行文件。
注意:PyroSim 被设计为与特定版本的 FDS 配合使用,版本信息在可执行文件路径下方标明。如果您指定了不同的版本,可能会遇到不可预测的 FDS 结果或错误。
处理器利用率优化
控制网格如何在可用 MPI 进程之间分配:
- 基本/默认(Basic/Default):PyroSim 将网格均匀分布在 MPI 进程之间。
- 无(None):PyroSim 允许 MPI 管理网格分配(PyroSim 2020.3 之前的默认行为)。MPI 将一个网格分配给所有可用 MPI 进程,但如果模型的网格数多于可用逻辑处理器数,最后一个 MPI 进程将被分配多个网格,可能导致模拟时间增加。
其他 FDS 设置
- 运行 FDS 前自动保存 PyroSim 模型:控制 PyroSim 是否在开始 FDS 模拟前自动保存当前 PyroSim 文件。
- FDS 模拟完成时运行结果:指定 FDS 模拟完成后是否自动启动 PyroSim 3D 结果。
并行执行设置
控制并行执行时生成的 MPI 进程数:
- 为每个网格创建进程(Create Process for Each Mesh):为每个 FDS 网格创建一个 MPI 进程。
- 基于逻辑处理器数限制进程(Limit Processes Based on Logical Processor Count,默认):为每个可用逻辑处理器创建一个 MPI 进程。
FDS GEOM 设置
控制与浸没边界障碍物相关的参数,这是未来 FDS 版本中即将推出的新型障碍物类型。不同于普通障碍物,浸没边界障碍物在写入 FDS 输入文件时不需要转换为块,而是由 FDS 使用其表面来切割 FDS 单元格,从而实现更精准的几何体表示。
- 启用 FDS GEOM:在 PyroSim 用户界面中启用对浸没边界障碍物的支持。选中后,会提供额外的编辑将障碍物转换为浸没边界障碍物,并写入 FDS 输入文件。导入包含浸没障碍物(
GEOM)记录的 FDS 文件时,必须选中此选项,否则这些对象将像其他障碍物一样被光栅化。 - 验证 GEOM 障碍物:指定在转换为浸没障碍物时是否验证障碍物的几何体。FDS 对浸没几何体的规范相当严格,要求对象的面必须形成一个封闭的流形体。验证过程尝试修正几何体中轻微的错误以确保生成封闭流形。这可能使转换稍慢,但有助于减少写入 FDS 输入文件时的几何体错误。建议保持此选项启用。
注意:启用 FDS GEOM 不会自动将所有障碍物视为浸没式,因为这样做可能严重影响模拟性能并导致其他几何体问题。障碍物必须使用上述方法之一手动转换。目前,建议只转换具有对模拟重要的弯曲或倾斜几何体的障碍物,例如倾斜的屋顶。
更改 FDS 版本
每个 PyroSim 版本都附带捆绑的 FDS。特定 PyroSim 版本针对捆绑的 FDS 版本进行了设计和测试。您可以使用 PyroSim 运行任意版本的 FDS,但 PyroSim 会基于捆绑的 FDS 版本生成输入文件,在更改 PyroSim 的 FDS 版本之前,了解不同 FDS 版本之间输入格式的差异很重要。
更改 PyroSim 使用的 FDS 版本的步骤:
- 从 NIST 下载并安装新版本的 FDS。
- 在文件菜单中,点击偏好设置。
- 在FDS 执行(FDS Execution)部分点击相应的文件夹图标,选择您希望 PyroSim 使用的可执行文件。
- 点击确定关闭偏好设置对话框。
Windows Defender 排除设置
Windows Defender 防病毒软件可能会导致 FDS 性能问题。PyroSim 在安装时会为捆绑的 FDS 可执行文件添加排除项,但如果使用自定义可执行文件路径,建议手动添加这些排除项。
为 FDS 可执行文件添加 Windows Defender 排除项的步骤:
- 使用Windows 搜索查找并打开Windows 安全中心。
- 在左侧菜单中选择病毒和威胁防护。
- 在病毒和威胁防护设置下,点击管理设置。
- 在排除项下,选择添加或删除排除项。
- 为 FDS 可执行文件路径添加文件和进程排除项。
- 如果使用 FDS 6.7.8 或更新版本,还需要为 OpenMP 优化可执行文件 fds_openmp.exe 的路径添加排除项(参见 OpenMP 优化相关文档)。
结果偏好设置

有一系列偏好设置控制在启动 FDS 模拟时 PyroSim 创建的文件,这些文件影响结果的显示(PyroSim 3D Results 或 Smokeview)。
- 在 CAD 文件中包含网格边界:是否在写入的任意 CAD 文件中包含网格的非开放边界。
- 输出 Views 文件:是否输出以 .views 扩展名结尾的文件。此文件包含模型中所有视图的信息(参见”视图”相关文档),并且只能由 PyroSim 3D Results 读取。启用视图文件会阻止视图信息写入 Smokeview INI 文件。
- 输出 PyroGeom 文件:是否输出包含所有 CAD、障碍物和通风口几何体的文件,可在 PyroSim 3D Results 中查看。此文件表示转换为 FDS 块之前的几何体,在 3D 结果中提供高质量的可视结果。如果对象有关联的控制逻辑,此文件中的对象还会被正确动画化(开启/关闭),这与 GE1 文件不同。
注意:此文件在 Smokeview 中不可查看。
- 输出 INI 文件:是否为 Smokeview 输出 INI 文件。此文件包含着色信息和一些初始化信息。如果输出 Views 文件未勾选,还会包含 Smokeview 的视图信息。
- 输出 GE1 文件:是否输出 GE1 文件。GE1 文件与 PyroGeom 文件类似,包含块转换前的 CAD、障碍物和通风口几何体。此文件格式在 PyroSim 3D Results 和 Smokeview 中均可查看,但有一些限制:
- CAD 纹理坐标可能无法正确映射。
- 具有控制逻辑的对象不会被动画化。
- 默认显示 GE1 文件:是否在 Smokeview 中默认显示 GE1 文件而非被捕捉的障碍物和通风口。此选项仅在输出 INI 文件也被选中时才能使用。
渲染偏好设置

这些偏好设置定义高阶 2D 和 3D 显示属性,可用于改善复杂模型的显示性能,但可能会对某些较旧的显卡产生问题,包括崩溃。因此,在安全模式下运行时这些选项会被关闭。
- GPU 信息:提供有关用于渲染 3D 和 2D 图形的图形硬件的信息。
- OpenGL 驱动程序(需要重启):指定运行软件时使用哪个 OpenGL 驱动程序。更改此值后必须手动重启 Results。
- 默认:使用系统上的默认 OpenGL 驱动程序(建议)。
- LLVMPipe:使用 Gallium LLVMpipe 驱动程序,提供可靠的基于软件的 OpenGL 实现。注意:可能比默认慢很多。
- D3D12:使用 DirectX 12 包装器,如果有可用 GPU 则会使用。在不原生支持 OpenGL 3.3 的系统上可能比 LLVMpipe 快,但此驱动程序在某些情况下可能不够可靠。
- 显示非默认驱动程序警告:如果使用了除默认以外的 OpenGL 驱动程序,是否在应用启动时显示警告。如果您计划排查默认驱动程序问题并打算稍后重新启用它,这会是一个有用的提醒。
- 多样本(Multisamples):控制抗锯齿设置以平滑对象的边缘。可用值取决于 GPU,通常范围为 0 到 16。值为 0 将关闭抗锯齿并使对象边缘看起来有锯齿。较大的值会提高视觉质量,但可能减少性能,具体取决于 GPU。值 4 通常在质量和速度之间提供合理的平衡。
- 各向异性过滤(Anisotropic Filtering):控制当纹理几何体以较大角度相对于相机查看时的纹理质量。可用值取决于 GPU,通常范围为 1 到 16,其中 1 关闭各向异性过滤。较大的值提高纹理质量。大多数 GPU 将此值设高时的性能影响可以忽略不计。
颜色方案
要在默认、黑色背景、白色背景或自定义颜色方案之间选择,请在视图菜单中点击颜色方案(Color Scheme)。
自定义颜色方案在 PyroSim 安装目录下的 PyroSim.props 文件中定义(Windows 10 中位于 %USERPROFILE%\AppData\Roaming\PyroSim\PyroSim.props,部分旧系统使用 C:\Program Files\PyroSim)。
定义自定义颜色方案的步骤:
- 关闭 PyroSim。
- 编辑
PyroSim.props文件。 - 将默认颜色更改为您需要的颜色(颜色值使用十六进制 RGB 格式,如
0xff0000表示红色)。 - 保存已编辑的
PyroSim.props文件。 - 重启 PyroSim。
偏好设置文件(PyroSim.props)
PyroSim 将用户偏好设置相关数据存储在名为 PyroSim.props 的文件中。默认情况下,此文件可在以下位置找到:
%APPDATA%\PyroSim\PyroSim.props%PROGRAMDATA%\PyroSim\PyroSim.props
如果这两个文件中存在任意一个,PyroSim 将使用它来加载用户偏好设置。如果两个文件都存在,PyroSim 将从两个文件中加载用户偏好设置,优先使用位于 APPDATA 文件夹中的文件。这样,位于 PROGRAMDATA 文件夹中的偏好设置文件可以在多台机器之间共享,而每台机器上 APPDATA 文件夹中的文件可以覆盖共享设置。
PROPS 文件以纯文本格式存储,可以使用任意常规文本编辑器查看或编辑。虽然不建议直接编辑该文件,但某些故障排查技术可能涉及删除 PROPS 文件,以便 PyroSim 从头创建新的文件。
PyroSim 中热键的配置存储在一个单独的文件 keybindings.json 中,位于 APPDATA 文件夹内。
-e1750215042767.png)