PyroSim 提供了一种名为视图(View)的对象,用于保存和恢复 3D 视图及 2D 视图的状态。视图还可用于指定裁剪区域,限制 3D 和 2D 视图中显示的模型范围。视图显示在导航面板中,如图 1 所示。

一个模型中可以有多个视图,但在任意时刻始终只有一个活动视图。新建模型始终以一个不含任意视图状态的默认视图开始。状态可以通过视点和剖面框两节中描述的方式添加到视图中。
视图在导航面板中进行管理,可在此创建、删除、分组、重新排列视图等。
创建视图
可通过以下方式之一创建视图:
-
- 在视图菜单中选择新建视图。
-
- 在导航面板中右键单击 Views 组,选择新建视图。
-
- 右键单击 2D 或 3D 视图中的空白区域,选择新建视图。
这将在模型中添加一个新视图,并将当前的相机视点和剖面框保存到新视图中(有关视点和剖面框的更多信息请参见后续章节)。新视图将成为活动视图。
删除视图
要删除视图,请在导航面板中选中该视图,然后在编辑菜单中选择删除。视图只有在非活动状态下才能被删除。
激活视图
通过以下方式之一激活视图:
-
- 在导航面板中双击视图或视图的视点。
-
- 在导航面板中右键单击视图,选择设为活动。
激活视图后将恢复其所有已保存的状态,详见后续章节。
复制与移动视图设置
视图设置可以在视图之间复制或移动。要复制视点或剖面框等设置,请在导航面板或编辑菜单中选择复制。要将设置粘贴到另一个视图,请选中目标视图并在编辑菜单中选择粘贴。要将设置从一个视图移动到另一个视图,请在导航面板中将设置拖动到目标视图。
注意:视点和剖面框只能移动到或粘贴到尚未包含视点或剖面框的视图中,具体取决于被粘贴的内容。
视点
每个视图可以关联一个视点。视点包含 2D 或 3D 相机的位置、方向、缩放和相机类型(3D 或 2D)。保存视点时,当前的导航工具(环绕、漫游等)也会一并保存。视点在导航面板中显示为视图的子项,标签为 Viewpoint。如图 1 中两个视图 Inside 和 Section 所示。
新建视图时会自动保存视点。视点也可以通过以下方式显式保存:
-
- 在视图菜单中选择保存视点,将视点保存到活动视图。
-
- 右键单击 2D 或 3D 视图中的空白区域,选择保存视点,同样保存到活动视图。
-
- 在导航面板中右键单击视图或视点,选择保存视点,保存到所选视图。
场景相机可通过以下方式重置到某个视点:
-
- 双击当前活动视图,将相机重置到该活动视图所保存的视点。
-
- 在导航面板中双击视点。如果该视点不属于当前活动视图,则会激活该视点所在的视图。
-
- 在导航面板中右键单击视点,选择重置到所选视点。
-
- 右键单击 3D 或 2D 视图中的空白区域,选择重置到视点,将重置到活动视图中的视点。
-
- 在视图菜单中选择重置到视点,同样显示活动视图中保存的视点。
可通过在导航面板中选中 Viewpoint 项并将其删除来移除视点。
激活包含视点的视图时,会发生以下情况:
-
- 根据保存视点时的活动状态,自动选择3D 视图或2D 视图。
-
- 恢复已保存的相机属性。
-
- 激活已保存的导航工具。
剖面框
视图还可以添加剖面框。剖面框是由六个面定义的一个凸形区域,用于限制可见几何体的范围,所有位于框外的几何体都会被裁剪。裁剪结果的示例如下图所示。


可通过多种方式创建剖面框:
-
- 右键单击尚未包含剖面框的视图,选择添加剖面框,将添加一个包围所有可见几何体的剖面框。
-
- 在视图菜单中选择添加剖面框,为活动视图添加剖面框(如果尚未包含)。
-
- 右键单击 2D 或 3D 视图中的空白区域,选择添加剖面框,同样为活动视图添加剖面框。
-
- 选中若干几何对象,右键单击其中之一,选择创建剖面。如果活动视图尚未包含剖面框,将添加一个仅包围所选对象的剖面框。如果活动视图已包含剖面框,将弹出对话框,提供替换活动视图剖面框或创建包含剖面框的新视图的选项。
注意:为活动视图添加剖面框后,选择工具将自动激活,以便快速编辑新的剖面框。更多信息请参见导航/选择。
剖面框显示为虚线轮廓区域。每个剖面框都关联一种颜色,用于显示剖面框轮廓和被裁剪的实体对象部分。在该图中,剖面框为绿色,因此被裁剪的所有几何体(包括墙壁和楼板)也显示为绿色。
剖面框的范围可通过选中它并像其他几何对象一样进行编辑,参见编辑对象。剖面框也可以像其他几何项一样旋转和移动,参见变换对象。

可通过双击剖面框或右键单击剖面框并选择属性来编辑剖面框的属性。
在视图菜单中取消选中启用剖面框,可在 2D 或 3D 视图中禁用活动剖面框。在视图菜单中取消选中显示剖面框,可独立隐藏剖面框的显示。
剖面框也可以通过以下方式重置为包围当前可见对象:
-
- 右键单击要重置的剖面框,选择重置剖面框。
-
- 在视图菜单中选择重置剖面框,将重置活动视图中的剖面框。
-
- 右键单击 2D 或 3D 视图中的空白区域,选择重置剖面框,同样重置活动视图中的剖面框。
注意:当查看设有特定活动楼层的剖面框时(参见楼层),裁剪区域为剖面框各面与楼层的 Z 向裁剪平面的交集。在此配置下,剖面框的顶面和底面不起作用。
与 Smokeview 的兼容性
Smokeview 支持视点概念,与 PyroSim 视图类似。Smokeview 视点由相机位置、方向、导航工具以及六个轴对齐的裁剪平面定义,视点存储在 Smokeview INI 文件中。
默认情况下,当 PyroSim 准备 FDS 模拟或导出 FDS 文件时,也会写入一个 Views 文件,该文件可在 PyroSim 3D 结果中读取但无法在 Smokeview 中读取。它不会将视图写入 Smokeview INI 文件,这是为了避免在 3D 结果中出现视图重复。不过可以通过在首选项中关闭 Views 文件来更改此行为(参见首选项)。关闭后,PyroSim 会将视图信息写入 INI 文件,因此可在 Smokeview 中读取。
随时可通过显式写入 PyroSim Views 文件或 Smokeview INI 文件来更新结果的视图信息,无需重新运行模拟。编辑方式:进入文件菜单,分别选择导出 → PyroSim 视点或导出 → Smokeview INI。
导出到 Smokeview INI 的限制
虽然 Views 文件可以按照 PyroSim 中的定义导出视图,但将 PyroSim 视图导出到 Smokeview INI 文件存在以下限制:
-
- 仅导出从3D 视图保存的视点对应的视图。
-
- 相机”翻滚”信息不会被导出,这意味着 Smokeview 中的视点方向可能与 PyroSim 不匹配。确保方向匹配的仅有方法是在 PyroSim 中使用漫游工具来调整相机方向。
-
- 缩放信息不会被导出。
-
- 仅导出未旋转的剖面框。
-
- 有时由于 Smokeview 中的近远裁剪平面选择不当,几何体在 Smokeview 中从导出的视点可能不可见。
此外,如果在 PyroSim 中使用漫游工具保存视图,Smokeview 中的旋转类型将设置为以眼为基点。对于其他所有导航工具,Smokeview 中的旋转类型将设置为双轴。
从 Smokeview 导入视点
Smokeview 视点也可以导入到 PyroSim 中。这在以下场景中很有用:在查看结果时在 Smokeview 中定义了额外的视点,并希望将这些视点保留到 PyroSim 中。导入 Smokeview 视点的方法:
-
- 在文件菜单中选择导入 FDS/CAD 文件。
-
- 选择与所查看 SMV 文件配套的 INI 文件。
注意:导入 Smokeview INI 文件还需要 PyroSim 读取对应的 SMV 文件。如果在 INI 文件所在的目录中找不到与 INI 文件同名的 SMV 文件,系统会提示用户选择 SMV 文件。
导入后,将添加一个新的视图组,其中包含 INI 文件中每个 Smokeview 视点对应的一个 PyroSim 视图。
-e1750215042767.png)